Welcome, Guest. Please login or register.
December 08, 2019, 11:21:58 PM
Home Help Search Login Register
News: retro-link - your friendly all-inclusive retro EVERYTHING community

+  retro-link.com
|-+  General Category
| |-+  Southern California Commodore & Amiga Network (SCCAN)
| | |-+  Ultimate64 ordered!
« previous next »
Pages: [1] Print
Author Topic: Ultimate64 ordered!  (Read 1420 times)
RobertB
Founding Member
Hero Member
*****
Posts: 2457



View Profile WWW
« on: June 02, 2018, 05:17:32 PM »

     Last night the pre-order list opened for the Ultimate64, and I ordered one.  http://www.ultimate64.com  The order was taken, and I don't have to pay until it is ready to ship.  It came to just under $218 US.

          Writing from Los Angeles,
          Robert Bernardo
          Fresno Commodore User Group - http://www.dickestel.com/fcug.htm
          Southern California Commodore & Amiga Network - http://www.portcommodore.com/sccan
          June 9-10 Pacific Commodore Expo NW 2018 - http://www.portcommodore.com/pacommex
          Aug. 11-12 Commodore Vegas Expo v14 2018 - http://www.portcommodore.com/commvex
Logged
sevk
Newbie
*
Posts: 10


View Profile
« Reply #1 on: July 07, 2018, 07:22:16 PM »

sweet! when do you expect to get it?
Logged
RobertB
Founding Member
Hero Member
*****
Posts: 2457



View Profile WWW
« Reply #2 on: July 08, 2018, 06:54:38 AM »

     Who knows?!  Smiley

          Truly,
          Robert Bernardo
          Southern California Commodore & Amiga Network -
          http://www.portcommodore.com/sccan
          August 11-12 Commodore Vegas Expo v14 2018 -
          http://www.portcommodore.com/commvex
Logged
RobertB
Founding Member
Hero Member
*****
Posts: 2457



View Profile WWW
« Reply #3 on: July 12, 2018, 06:31:46 AM »

     Ah, I just received a production update today.  It seems that the one I ordered will be ready in early October.

          Not in time for CommVEx,
          Robert Bernardo
          Fresno Commodore User Group -
          http://www.dickestel.com/fcug.htm
          August 11-12 Commodore Vegas Expo v14 2018 -
          http://www.portcommodore.com/commvex
Logged
RobertB
Founding Member
Hero Member
*****
Posts: 2457



View Profile WWW
« Reply #4 on: December 19, 2018, 08:17:50 AM »

     Heh, it wasn't ready in October, but I received notice that it was ready a few days ago.  I sent in my money, and it has been shipped!  I should have it in a few days.

          Back in California,
          Robert Bernardo
          Southern California Commodore & Amiga Network - http://www.portcommodore.com/sccan
Logged
RobertB
Founding Member
Hero Member
*****
Posts: 2457



View Profile WWW
« Reply #5 on: January 12, 2019, 07:23:03 AM »

     The Ultimate 64 arrived on Dec. 27, and I plan to show it at the SCCAN and FCUG (and maybe TOGA) meetings in January.

          Truly,
          Robert Bernardo
          Fresno Commodore User Group - http://www.dickestel.com/fcug.htm
          Southern California Commodore & Amiga Network - http://www.portcommodore.com/sccan
          The Other Group of Amigoids - http://togausergroup.org
Logged
RobertB
Founding Member
Hero Member
*****
Posts: 2457



View Profile WWW
« Reply #6 on: February 09, 2019, 07:30:24 AM »

     At the FCUG meeting, the U64 was tested with a Koalapad and its Koalapainter cartridge.  The U64 failed!  It understood when the stylus was pressed against the tablet, but it would not move the cursor lower than midpoint down the screen.  Sad  More testing to be done...
     With the board fitted into a brown C64 case, I don't like that it's only supported by 3 screws.  Therefore, I have taken member Bogdan's advice and have ordered 3-D printed brackets which will firmly hold onto the U64.  I got them from CoreI64, specifically on this page -

https://corei64.com/shop/index.php?route=product/category&path=65_66

     Truly,
     Robert Bernardo
     April 27-28 Commodore Los Angeles Super Show - http://www.portcommodore.com/class
     June 8-9 Pacific Commodore Expo NW - http://www.portcommodore.com/pacommex
Logged
RobertB
Founding Member
Hero Member
*****
Posts: 2457



View Profile WWW
« Reply #7 on: February 23, 2019, 08:26:44 AM »

     At last Sunday's FCUG meeting, things were going well with the U64 until the very end of the meeting.  It would not display a screen and when it did, it would be a blank screen.  Powering down and powering up was iffy.  Sometimes there would be a blank screen, sometimes just black.  Sad  It was very flaky.  I'm hoping that the cause is the cheapy, wall wart that was shipped with it.  If I replace it with a regulated, 12V, 2 amp. power supply, perhaps that would cure its problems.

     Truly,
     Robert Bernardo
     April 27-28 Commodore Los Angeles Super Show - http://www.portcommodore.com/class
     June 8-9 Pacific Commodore Expo NW - http://www.portcommodore.com/pacommex
Logged
RobertB
Founding Member
Hero Member
*****
Posts: 2457



View Profile WWW
« Reply #8 on: July 31, 2019, 01:28:23 AM »

Sometimes there would be a blank screen, sometimes just black.
     At a SCCAN meeting, it was discovered that a bad s-video cable was the cause.
     I have been using the Ultimate 64, showing it off at club meetings, the Commodore Los Angeles Super Show, Bay Area Maker Faire, and the Pacific Commodore Expo.  And I have been satisfied with it.
     However, at our last FCUG meeting a few weekends ago, I had trouble with it.  I ran the new C64 games, Crystal Caverns, Death Weapon, Run Demon Run, Super Goatron, Stercore XD, Super Galax-I-Birds, Royal Hunt, and Robots Rumble.  No sound came from any of the games!  I checked my settings in the U64 menus.  Nothing had been changed...
still using the internal UltiSIDs, still in PAL mode, still using HDMI.  I cross-checked with a regular C64 and Commodore CRT monitor; the games' sound worked perfectly.  The club members and I were stumped for awhile; we couldn't figure out what was wrong.  I thought perhaps the HDMI cable had gone bad or that the external speakers
connected to the monitor had gone bad.
      Then we tried playing some SID tunes through the U64.  It worked!  But still nothing with the new games.  Finally, one member suggested that I go back to the older 1.18 firmware, instead of using the new 1.21 firmware.  I reflashed the board, and older firmware solved all the sound problems!  Now I had sounds coming through the games.  Now I could relax and show off the U64 at CommVEx.

          Truly,
          Robert Bernardo
          Southern California Commodore & Amiga Network - http://www.portcommodore.com/sccan
          Fresno Commodore User Group - http://www.dickestel.com/fcug.htm
          August 10-11 Commodore Vegas Expo v15 - http://www.portcommodore.com/commvex
Logged
Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines web space for free online dating site hosting Valid XHTML 1.0! Valid CSS!